1. We are no longer supporting TapaTalk as a mobile app for our sites. The TapaTalk App has many issues with speed on our server as well as security holes that leave us vulnerable to attacks and spammers.
    Dismiss Notice

2006 Apex no fuel pump!

Discussion in 'Electrical' started by brapcounty, Nov 15, 2017.


  1. brapcounty

    brapcounty Newbie

    Messages:
    7
    Location:
    Washington State
    Country:
    USA
    Snowmobile:
    2006 Apex Mountain
    MCXpress turbo
    I have an external fuel pump in my Apex, it is not receiving power when i turn the key. Starter works fine. I have replaced the starter relay and the main switch. I have also checked the grounding blocks for corrosion and tested all four relays near my left foot..... still no power to the fuel pump. It appears that the power for the fuel pump comes from the ecu. With the ignition in the ON position, I have 12v on the blue/white and red/white wires at the starter relay, although, I am not getting 12v at the starter relay on the red/green wire.
    Any help is appreciated.
     
  2.  
  3. steveg_nh

    steveg_nh VIP Member VIP Member

    Messages:
    566
    Location:
    Southern NH
    Country:
    USA
    Snowmobile:
    2007 Attak
    Any corrosion on the wire harness for the starter relay? Mine had some, and some black oxidation that prevented a good connection.
     
  4. brapcounty

    brapcounty Newbie

    Messages:
    7
    Location:
    Washington State
    Country:
    USA
    Snowmobile:
    2006 Apex Mountain
    MCXpress turbo
    there was a little, I cleaned it out with electrical connector cleaner. Just got back in, I took the wires out of the connector and inspected them. Looked really good.
     
    Last edited: Nov 15, 2017
  5. brapcounty

    brapcounty Newbie

    Messages:
    7
    Location:
    Washington State
    Country:
    USA
    Snowmobile:
    2006 Apex Mountain
    MCXpress turbo
    any other suggestions?
     
  6. maim

    maim Moderator Staff Member Moderator Lifetime VIP Member VIP Member

    Messages:
    4,166
    Location:
    sudbury on
    Country:
    Canada
    Snowmobile:
    2011 apex xtx/ 2009 phaser rtx/x/ 1997 et410t/r
    fuel pump relay is good?
     
  7. brapcounty

    brapcounty Newbie

    Messages:
    7
    Location:
    Washington State
    Country:
    USA
    Snowmobile:
    2006 Apex Mountain
    MCXpress turbo
    Thanks for the prompt Maim. I went back and took another look at the new relay that I replaced and apparently somebody had switched out the starter relay in the past with one from a grizzly therefore I was getting a common negative to my pigtail rather than a common positive to my pigtail with the proper relay in place. I switch the poles on the starter relay and Eureka! Everything works great. I love this site a lot of good ideas thanks for the help.
     
    maim likes this.

Share This Page


  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice