• We are no longer supporting TapaTalk as a mobile app for our sites. The TapaTalk App has many issues with speed on our server as well as security holes that leave us vulnerable to attacks and spammers.

2007 phazer won’t start


Jan 3, 2010
East Hartland, CT
2007 phazer won’t start, just cranks and cranks. It originally had some error codes and I erased them. Sled ran and idled for about a minute and wouldn’t start again. Now no codes are present in the diagnostic program but if you scroll to the clear codes number it states there are 2 codes in the system and it won’t let me clear them.

Also Currently the Speedo is reading 33mph while the key is on and the check engine light is on and warning light is flashing. But still no codes flashing.

I’ve tried a few things. Grounds are good, battery is charged and all diagnostic features seem to be checking out.

It won’t fire on starter fluid
It does seem to backfire when you turn key off. ( like the spark plugs fire when to turn key off)

Any thoughts would be appreciated. I feel like it’s gotta be something stupid, or the computer is fried.

What codes did you have? Did you check for spark? Check all the fuses? Check for power and ground at the coils? If you have the manual, look over the schematics and check power where there should be. It also has instructions on how to check the trigger coil in the stator. It is known to sometimes fail.
The codes I had were #11 , cylinder identification sensor, #13 cylinder 1 intake pressure, #22 Intake air sensor, # 25 cylinder #2 intake air temp sensor, #30 Oil pressure drop signal, #81 Grip warmer, #88 drive positioning. I realize this is a lot of stuff. But no codes have come back. All diagnostic sequences work as functioned, relays, injectors, coil packs, etc. Something is telling the engine not to fire.
All fuses are good. Guess I gotta really dig into it
Check your wiring too in case of a rodent having a snack. Just learned that a lot of automotive wiring's sheathing is made with soy so it attracts them.