1. We are no longer supporting TapaTalk as a mobile app for our sites. The TapaTalk App has many issues with speed on our server as well as security holes that leave us vulnerable to attacks and spammers.
    Dismiss Notice

Mtx overheated ?

Discussion in 'Phazer & Phazer MTN General Talk' started by EJ R., Feb 8, 2019.


  1. EJ R.

    EJ R. Veteran

    Messages:
    31
    Location:
    Wyoming
    Country:
    USA
    Snowmobile:
    2014 xtx phazer
    Was -15 yesterday rode all day on off trail got back on groomed and within 5 miles it overheated. Yellow light and temp icon came on. 2014 mtx 528 miles I'm wandering if the exchanger was blocked off with ice. Fan was working coolant was full. All I've done to it was an mbrp pipe and changed oil that's it. I also noticed the thing idles around 2000 rpm. Coolant is a blueish color tester only goes to -50 and coolant is good to -50 wandering if its too rich ? Thanks
     
  2.  
  3. Mooseman

    Mooseman Lifetime Member Lifetime VIP Member VIP Member

    Messages:
    3,094
    Location:
    Greely, Ontario
    Country:
    Canada
    Snowmobile:
    '07 Venture MP
    '07 Phazer FX (gone)
    '09 Phazer GT
    '10 RS Venture GT
    '10 Nytro FX
    Could be an ice dam. When that light comes on, it's not actually overheating but a pre-overheating warning. If it was overheating, it would shut down. When it comes on, just stop and let the fan and radiator do their work. The light should go off after about 5 minutes. If not, then you have bigger problems.

    That's why I installed a temp gauge.
     
    EJ R. likes this.
  4. ATV PRO #11

    ATV PRO #11 Lifetime Member Lifetime VIP Member VIP Member

    Messages:
    1,040
    Location:
    Garson, MB, CANADA
    Country:
    Canada
    Snowmobile:
    2014 Yamaha Phazer XTX
    I’ve seen that light only once in 26k on my Phazers. Crossing black ice lake. No snow. Didn’t shut down. Was minus 30 with wind chill of minus 40 at the time.
    Probably ice damn if off trail.
    Drop ur idle down to 16-1700rpm.
    Just above a-arm brake side you’ll see a little black plug 3/8” round. Pop it out and Phillips to turn idle down. Counter clockwise.

    Fan on hot
    Fan on and yellow light ur really hot
    Shuts down extremely hot.
    I’ve yet to see one boil over
     
    EJ R. likes this.
  5. EJ R.

    EJ R. Veteran

    Messages:
    31
    Location:
    Wyoming
    Country:
    USA
    Snowmobile:
    2014 xtx phazer
     

    Attached Files:

  6. YukonMP

    YukonMP TY 4 Stroke Junkie

    Messages:
    563
    Location:
    Yukon Territory
    Country:
    Canada
    Snowmobile:
    2014 Yamaha MultiPurpose
    I expect your manual will spec the coolant at 60/40 which gives more freeze protection but less efficient cooling than weaker mixes. I haven't seen that light since I diluted to 50/50 with Water Wetter.

    That is one iced up sled, looks like you were having fun.
     
  7. EJ R.

    EJ R. Veteran

    Messages:
    31
    Location:
    Wyoming
    Country:
    USA
    Snowmobile:
    2014 xtx phazer
    Thanks. Shouldn't have to worry about lean condition with that pipe right ?also wandering if I should change coolant since its 4 years old ? If so what coolant should I run? Its a blueish color antifreeze
     
  8. EJ R.

    EJ R. Veteran

    Messages:
    31
    Location:
    Wyoming
    Country:
    USA
    Snowmobile:
    2014 xtx phazer
    Yes it was fun crossed a few creeks with overflow. I'm sure that didn't help much. What is water wetter ?
     
  9. ATV PRO #11

    ATV PRO #11 Lifetime Member Lifetime VIP Member VIP Member

    Messages:
    1,040
    Location:
    Garson, MB, CANADA
    Country:
    Canada
    Snowmobile:
    2014 Yamaha Phazer XTX
    528 miles and it’s a 14 :carbs:

    Yukon’s probably right. It’s more effective cooling at 50/50. Hearing you were in water that’s probably all it was. A lot of ice.

    Pipe wise I’m unsure of lean conditions. Honestly I don’t think so. Reason I say that is I warm my hands with exhaust. I’m piped again. Excell. My white n blue gloves are getting a black exhaust soot on them. Didn’t have before I bolted it on. And my tail pipe is ever so slightly black. Very light carbon build up.
    My stock didn’t have any black. Was light brown. Love that exhaust out the rear like that. Been minus 30’s here for long time. Stop sign I lean back. Warm em up and carry on.
     
    EJ R. likes this.
  10. YukonMP

    YukonMP TY 4 Stroke Junkie

    Messages:
    563
    Location:
    Yukon Territory
    Country:
    Canada
    Snowmobile:
    2014 Yamaha MultiPurpose
    I bet your blue coolant is Yamacool. My dealer recommends replacing the coolant at 5 years. Water Wetter is one of three coolant additives I commonly see mentioned on TY. They all seem to work well. They make the heat transfer more efficient, not night and day different, but a step in the right direction that seems enough for a lot of guys, that and getting down to 50/50.
     
    EJ R. likes this.
  11. EJ R.

    EJ R. Veteran

    Messages:
    31
    Location:
    Wyoming
    Country:
    USA
    Snowmobile:
    2014 xtx phazer
    Lol your right I just got it a month ago and it only had 200 on it. I love the rear exit exhaust -25 the other day my foot got cold rode with my knee on seat toes on the exhaust warmed em up. I still think it was more of an ice jam. The light went off as soon as I dipped off the trail its been in the 30 s and 40 s most this winter and it never got warm
     
    ATV PRO #11 likes this.
  12. EJ R.

    EJ R. Veteran

    Messages:
    31
    Location:
    Wyoming
    Country:
    USA
    Snowmobile:
    2014 xtx phazer
    So should I use that again or is the all make extended life OK ? They had thAt same blue stuff in my kawi dirt bike I bought from the yamaha shop I started running the blue Asian antifreeze from honda in all our bikes and atv
     
  13. ATV PRO #11

    ATV PRO #11 Lifetime Member Lifetime VIP Member VIP Member

    Messages:
    1,040
    Location:
    Garson, MB, CANADA
    Country:
    Canada
    Snowmobile:
    2014 Yamaha Phazer XTX
    Wouldn’t worry about your antifreeze.
    Parts store grab some PH strips.
    If your ph is 10 it’s still good and probably will be for long time since your at 500miles.
    Anything lower than 9 it’s getting too acidic and time for a change.
    Can dilute too for better cooling effect as well. Mine was way too strong from factory.
     
    EJ R. likes this.
  14. YukonMP

    YukonMP TY 4 Stroke Junkie

    Messages:
    563
    Location:
    Yukon Territory
    Country:
    Canada
    Snowmobile:
    2014 Yamaha MultiPurpose
    Thank you, that is a great tip. It is stuff like this that makes my friends think I'm a fricken genius.
     
    ATV PRO #11 and EJ R. like this.
  15. EJ R.

    EJ R. Veteran

    Messages:
    31
    Location:
    Wyoming
    Country:
    USA
    Snowmobile:
    2014 xtx phazer
    Thanks guys for all your help
     
    ATV PRO #11 likes this.
  16. maim

    maim Moderator Staff Member Moderator Lifetime VIP Member VIP Member

    Messages:
    4,785
    Location:
    sudbury on
    Country:
    Canada
    Snowmobile:
    2016 apex xtx/ 2011 apex xtx/ 2009 phaser rtx/x/ 1997 et410t/r
    thanks for the tip on idling will let it cool down when fan is on. the 09 is set up like an xtx and i had the light come on in 1-1/2' of power ripping across the lake but i was not stopping as there was 1' of slush under the snow. stopped on trail and light was on. puked 1l of coolant out when i shut it down and flipped it on its side to clean it out. cooler was completely covered by ice over 4" thick. might have been the powder riding at -30 c. i know apex's will not cool down like that when they get that hot with only the rad and fan running.
     

Share This Page


  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice