1. PLEASE READ: If you have problems logging in with your old password, click the Forgot Password link in the log in screen to get an email verification to request a new password or click Here. If you haven't received a new password from the forum please email your username and password to webmaster@totallyamaha.com. Sorry for the inconvenience.
    Dismiss Notice
  2. All hotmail, msn, outlook, live email accounts are not receiving email notifications. The only way to remedy this is to add @totallyamaha.com to your safe senders list in order to receive notifications.
    Dismiss Notice
jaydaniels
Last Activity:
Jan 22, 2018 at 4:25 AM
Joined:
Dec 10, 2008
Messages:
477
Likes Received:
23
Trophy Points:
723
Location:
Amherst NS Canada
Occupation:
Operations Manager

Share This Page

jaydaniels

Expert, from Amherst NS Canada

jaydaniels was last seen:
Jan 22, 2018 at 4:25 AM
    1. Henny596
      Henny596
      I was worried maybe I mixed up the cams and put the intake in the exhaust side, I have it all timed tho, lobes are in correct position, marks line up, just don’t like the clicking noise it makes from the chain/ gear area.
      Thanks for any information you can offer
    2. Henny596
      Henny596
      Hey Jay I was just reading over your Nytro build, I’m having a similar issue as I rotate the motor, can chain going tight then loose.. was it fine after you started it and the tensioner tightened up? Sorry I know it’s an old thread!
  • Loading...
  • Loading...
  • About

    Location:
    Amherst NS Canada
    Occupation:
    Operations Manager