• We are no longer supporting TapaTalk as a mobile app for our sites. The TapaTalk App has many issues with speed on our server as well as security holes that leave us vulnerable to attacks and spammers.

fuel starvation at wot

sgilbert

TY 4 Stroke Guru
Joined
Mar 28, 2009
Messages
808
Location
Charlemont, Massachusetts
have almost 10,000 mi. for the last 1000 has had a slight fuel starvation at wot. at first thought it was the rev limiter, until I watched the tach. no problem up to like 7/8 throttle, just half the time at wot it starves enough to notice. the only filter I see is on the pump. anyone else experience this?
 

drag123

Veteran
Joined
Feb 16, 2009
Messages
31
Location
Ottawa
Country
Canada
Snowmobile
08 fx nytro
sgilbert said:
have almost 10,000 mi. for the last 1000 has had a slight fuel starvation at wot. at first thought it was the rev limiter, until I watched the tach. no problem up to like 7/8 throttle, just half the time at wot it starves enough to notice. the only filter I see is on the pump. anyone else experience this?


Have you checked your air filter lately?
 

sgilbert

TY 4 Stroke Guru
Joined
Mar 28, 2009
Messages
808
Location
Charlemont, Massachusetts
drag123 said:
sgilbert said:
have almost 10,000 mi. for the last 1000 has had a slight fuel starvation at wot. at first thought it was the rev limiter, until I watched the tach. no problem up to like 7/8 throttle, just half the time at wot it starves enough to notice. the only filter I see is on the pump. anyone else experience this?


Have you checked your air filter lately?
no, its a snow screen, doubt its plugged, plus I blocked the inlet off with mechanics cloth when new to keep critters out and its starving, not choking
 

canoehead

TY 4 Stroke God
Joined
Jan 14, 2011
Messages
2,135
Location
NE, Alberta
Country
Canada
Snowmobile
2014 XF9000, 2016 Viper XTX
What are your rpm's when it starts to blubber?
 

sgilbert

TY 4 Stroke Guru
Joined
Mar 28, 2009
Messages
808
Location
Charlemont, Massachusetts
donuts are fine and have changed them before, were fine then too. just got back from 530 miles. definetly starving. either a kinked line or obstruction of some sort
 

swmpr1

Extreme
Joined
Nov 20, 2006
Messages
82
interesting, came on tonite to see if anyone else has had this happen.. mine just started doing it at about 12,000 miles, I changed plugs, coils, fuel, has new donuts, still does it. it now has 13,000 miles and still bugs me as to what it is. feels like a hesitation under hard load about 3/4 to full throttle and just above 9k rpms. sounds like a misfire or stutter.. do these have rev limiters?
 
Joined
Mar 12, 2015
Messages
9
Age
28
Location
Parrsboro NS
Country
Canada
Snowmobile
08 Nytro
What did you find out? I have a problem that is similar to this, just mine is happening at about 5000 rpm and is only doing it when warm, not bringing up any codes
 
Joined
Mar 11, 2009
Messages
172
Location
Central WI
not sure if this can help or is part of the problem ,but the stub shaft for the primary clutch ( part # 8GL-11406-00-00 SHAFT ASSY ) has a kind of a gear on the inside of this may become loose ,( this is also part of the "clutch" rattle we`ve learned to live with )
not sure what this gear all does but I believe it controls timing and pretty much tells the motor (ECU ?) what position the crankshaft is in.
 


Top