• We are no longer supporting TapaTalk as a mobile app for our sites. The TapaTalk App has many issues with speed on our server as well as security holes that leave us vulnerable to attacks and spammers.

Intermittent no start / idle shutoff / start but zero power


Feb 27, 2023
Apex XTX 2013 144x1.77x15
Rs Venture TF 2011 151x1.25x15
Hi guys

Brother in law bought a RS venture GT ´09 with 15500km.

Ran great at first, took it out on the trail, 10km further we stop and it shut off at idle, start back fine but shut down if left idling.
A km or two further, slowing down to do a u-turn and it will not move, engine seems to cut, zero power, cant even get the track to spin when in the air.
When turned off, will only start with throttle at first, then not at all.
Towed it back to the trailer and it start right up. Did a couple run, turned it off, wont start again.

Put it on the trailer, got home, started right away. Changed spark plug and sent him for a ride, 10 min later he calls me, need a tow, started to cut power making it come to a stop, turned it iff then wont start. Got it home, put the charger on it, couple min later we try it again, start right up.

We left it at that for now

Should add that we can hear the fuel pump when turning the key, tried cycling the key many time before attempting to start, to no avail.
check that is is charging. if it is, most likely needs a new battery.
Check the ground wire coming from battery. It has a spade connector that can corrode and intermittently lose connection. It would usually throw an error on the display like ER-1.
Ok so we took it out a couple times again.it’s actually not that intermittent. Will start great when cold, idle great, drive great, for about 10 min. Then it will start to quit, die, need throttle to start back up then wont idle for long or wont start at all. Unable to gain speed. If left to cool for a while, will start right back and drive great.

At that moment we mesured voltage at battery, 12,8v when off, 14v while idling.
We visually inspected wiring harness, no visible cut.
Unplugged and replugged all connector, no visible burn, melt or rust.
We unplugged fuel line at fuel rail and it seems to have a good flow, did not mesure pressure as i dont have tool or adapter for it.
Tried swapping ecu with my GF ‘11 efi rs venture, no luck.

Thanks guys!
Sounds like a fuelling issue to me. I'd check the voltage going to the fuel pump and actual pressure going to the fuel rail. Flow does not mean it has adequate pressure.
Sounds like a fuelling issue to me. I'd check the voltage going to the fuel pump and actual pressure going to the fuel rail. Flow does not mean it has adequate pressure.
Thank you for your answer!
I agree, but dont have a fuel pressure tester nor the adapter from Yamaha. As we can see the injectors in the throttle bodies when WOT, would a visual check there be a good test?
Again ty for your input, very appreciated!
No because at WOT it's in flood clearing mode and would not spray fuel. Check on Amazon for a tester kit that has a lot of different adapters and fittings. It should have one in there that would work, like this one, which specifies also for ATVs.

And here's the procedure from the manual. It's done at the pump.


This guy found a way to do it with some ordinary fuel line and a T on a Yamaha R1 motorcycle.



  • 1678049067294.png
    222.4 KB · Views: 54
Last edited:
Hi guys!
Instead of buying a fuel pressure testor we swapped a known good fuel tank/fuel pump asy from my GFs '11 Venture
Same issue, rode for about 10-15 min, all great, then starts to cut out, no power, comes to a full stop, dies. We were able to restart and get it back home on its own but it had no power, it cuts and pop and bang, max 5-10kmh. Battery was at 12.something V when we got back home.
Went thru diagnostic mode, no stored codes. Did test d.01, 03, 04, 05, 06, 07, 09, 36, 37, 38. Can we test coil D.30, 31, 32 without the PET-4000 spark cheker by just putting the spark plug in the coil with electrode touching motor head?


What other parts would you try swapping with a known good sled?
I'd like to test the Stator, is this test procedure for the grizzly applicable to our Venture EFI? https://www.partzilla.com/blog/yamaha-grizzly-yfm700-stator-testing-replacement
Cant find a full test in the service manual other than test the coil resistance wich tested ok (when cold anyway)

Could it be out of spec valve adjustment? Run great when cold, run very bad / does not run when fully warmed?

Thanks alot!
I would check TORS and look and see if your driveshaft bearing has went out and eaten your speedometer sensor.