1. We are no longer supporting TapaTalk as a mobile app for our sites. The TapaTalk App has many issues with speed on our server as well as security holes that leave us vulnerable to attacks and spammers.
    Dismiss Notice

Phazer 2009 no start

Discussion in 'Phazer & Phazer MTN General Talk' started by Trevorj, Nov 30, 2019.


  1. Trevorj

    Trevorj Newbie

    Messages:
    12
    Location:
    Lisle
    Country:
    Canada
    Snowmobile:
    Phazer/ vector
    Hi guys new guy here. Have 09 phazer. Won't start. Will not crank over. Turn key on. Fuel pump will not turn on either. I can jump starter solenoid and it cranks. Yellow ground block looks ok but?. Any suggestions. Thanks
     
  2.  
  3. cannondale27

    cannondale27 Moderator Staff Member Moderator Vendor Lifetime VIP Member VIP Member

    Messages:
    18,657
    Location:
    Manitowoc,WI
    Sure sounds like that block. Take a pic
     
    Mooseman likes this.
  4. Mooseman

    Mooseman Lifetime Member Lifetime VIP Member VIP Member

    Messages:
    3,141
    Location:
    Greely, Ontario
    Country:
    Canada
    Snowmobile:
    '07 Venture MP
    '07 Phazer FX (gone)
    '09 Phazer GT
    '10 RS Venture GT
    '10 Nytro FX
    Does the gauge come on? Open that ground block and look for burnt terminals.
     
  5. Trevorj

    Trevorj Newbie

    Messages:
    12
    Location:
    Lisle
    Country:
    Canada
    Snowmobile:
    Phazer/ vector
     
  6. Trevorj

    Trevorj Newbie

    Messages:
    12
    Location:
    Lisle
    Country:
    Canada
    Snowmobile:
    Phazer/ vector
     

    Attached Files:

  7. Trevorj

    Trevorj Newbie

    Messages:
    12
    Location:
    Lisle
    Country:
    Canada
    Snowmobile:
    Phazer/ vector
    Cluster turns on. All fuses good.
     
  8. Mooseman

    Mooseman Lifetime Member Lifetime VIP Member VIP Member

    Messages:
    3,141
    Location:
    Greely, Ontario
    Country:
    Canada
    Snowmobile:
    '07 Venture MP
    '07 Phazer FX (gone)
    '09 Phazer GT
    '10 RS Venture GT
    '10 Nytro FX
    One connector at the end looks dark. Does it have the black secondary smaller ground block nearby? If not, I'd suggest doing the ground block update as per this bulletin. You don't need the actual kit from Yamaha, just solder the indicated wires together or use a similar connector.

    After that, you should break out a multimeter or test light and, along with a schematic from the repair manual, check for power and ground. At this point, there's no way around that. If it was just the fuel pump not running and it cranks, I would have said to check the pump relay. I would highly recommended to replace with the red solid state version anyway for very cold start issues.
     

    Attached Files:

  9. Trevorj

    Trevorj Newbie

    Messages:
    12
    Location:
    Lisle
    Country:
    Canada
    Snowmobile:
    Phazer/ vector
    Thanks mooseman. Do I solder 5&6 together then run a ground to the battery from 5&6. Ya I will have to pick up a schematic. Thanks for your help I will try tonight
     
  10. Mooseman

    Mooseman Lifetime Member Lifetime VIP Member VIP Member

    Messages:
    3,141
    Location:
    Greely, Ontario
    Country:
    Canada
    Snowmobile:
    '07 Venture MP
    '07 Phazer FX (gone)
    '09 Phazer GT
    '10 RS Venture GT
    '10 Nytro FX
    Yep.
     
  11. Trevorj

    Trevorj Newbie

    Messages:
    12
    Location:
    Lisle
    Country:
    Canada
    Snowmobile:
    Phazer/ vector
    Connected 5&6 to battery. Cranks over now sweet. But still no fuel pump. Does 5&6 control all the grounds now? Or is it possible I'm still missing a ground from the yellow block to the fuel pump relay. Or should I just change fuel pump relay and hope for the best. Is fuel pump relay called fuel injection relay. I don't see fuel pump relay on schematic. Does anyone know which one it is out of the all of them that are there. Thanks kindly.
     
  12. 74Nitro

    74Nitro VIP Member VIP Member

    Messages:
    1,664
    Location:
    Dublin Ontario
    Country:
    Canada
    Snowmobile:
    2019 Sidewinder LTX
    The one with the most red(or red tracers) wires.
    And yes, Yamaha calls it a fuel injection relay.
    Any codes showing on dash at the moment?
     
  13. Trevorj

    Trevorj Newbie

    Messages:
    12
    Location:
    Lisle
    Country:
    Canada
    Snowmobile:
    Phazer/ vector
    No codes. I guess I could jump relay. To see if turns on. I will try again tomorrow. Thanks for help
     
  14. 2stroken

    2stroken Pro

    Messages:
    167
    Location:
    Western Michigan
    Part number for the fuel relay?
     
  15. Mooseman

    Mooseman Lifetime Member Lifetime VIP Member VIP Member

    Messages:
    3,141
    Location:
    Greely, Ontario
    Country:
    Canada
    Snowmobile:
    '07 Venture MP
    '07 Phazer FX (gone)
    '09 Phazer GT
    '10 RS Venture GT
    '10 Nytro FX
    8GN-81950-00
    Could be the relay. These should help.
     

    Attached Files:

  16. Trevorj

    Trevorj Newbie

    Messages:
    12
    Location:
    Lisle
    Country:
    Canada
    Snowmobile:
    Phazer/ vector
    Thanks mooseman I will try it out.
     

Share This Page


  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice