• We are no longer supporting TapaTalk as a mobile app for our sites. The TapaTalk App has many issues with speed on our server as well as security holes that leave us vulnerable to attacks and spammers.

Carb question

Do you have the paper service manual for the carbs?I hate to say it but if it was me I would pull them apart 1 carb at a time&make sure all the parts are in place per the manual&clean&set at proper adjustment.the problem is there just gotta find where.it sucks to do a job 4-5 times but stay calm&patience will prevail you will find it& its probably 1 little thing but that's all it takes.hang in there you will figure it out.i have the troubleshooting pages if you need them (you may have already checked?)

I do have the complete service manual on my computer but my computer is not working at the moment. Yes the problem is there and it’s most likely a simple one because it ran fine before cleaned them

Also I had notes from previous overhaul that there is a tiny oring&tiny flat washer for the pilot screws that are not shown in the service manual.the oring goes in first then the washer&then the pilot screw
Yes the pilot screws are all fine. I had to replace a lost o ring though.
Well I went through the carbs meticulously again and adjusted the pilot screws to 2.5 turns as mentioned in one of the above posts rather than the 2 turns I had them. I can actually drive it around now but since I disturbed the float needles and seats again two of the other carb are doing the same thing that was happening in my original post that started this whole thing. I will order 3 more needle and seat kits and then all of them will be new. I’m thinking that it was the misadjusting of the pilot screws that was the main cause of the problem the whole time. But it was only a matter of time before the needles and seats were leaking and causing more issues. I will report back after I change them out. After my family’s ski vacation
Last edited:
I’m reviving my old thread, simply because the sled is still doing this.
Here’s where I’m at.
I received and installed the new needles and seats last year but by that time our snowmobile season was over and the carbs were clean and dry of fuel so I thought it would save me the extra work of having to drain them again for storage. Well I started it up today and it idles fine but will stall out when I try to move it. If I put the choke on I can drive it. I was really hoping that the problem would be fixed. I really have no idea what else to do. Sled was running fine before I removed the carbs to do some routine cleaning at the beginning of last year and I have been fighting with this problem ever since.
I order replacement parts for all of these (7, 10, 15, 16, 27, 28, & 29) but like stomper #16 was actually replaced with new OEM 165's as I run the ECP Filter kit. I even bought two new fuel tank filters so hopefully I get old Black Betty running like her ole self soon.

I was finally able to finish my carb rebuild which also included rebuilding the fuel pumps (yes there is now a kit available to replace internals w/o buying the complete fuel pump assy and only cost $10) and sync'ing the carbs and now the RX-1 is back to running like her old self. Not sure if it was just one component or a combination of things. I definitely felt replacing the needle valve assy was needed but considering I always cleaned and soaked the jets and ensured the holes were clear, I really wasn't sure the jets or even the pilot jet assy needed to be replaced. Whatever it was I am glad to have it running as I was in the same boat as you. It had ran flawlessly the last time it was used but then sat a few years after cleaning the carbs with the fuel drained from the tank and none in the carbs; never started it after cleaning carbs thinking the next time I want to use it I would only need to add fuel and sync the carbs. Unfortunately that wasn't the case and considering the RX-1 had over 11,000 miles, decided to rebuild the carbs, replace tank fuel filters and rebuild fuel pump.
After replacing all four needle and seat kits, are you still having issues like you did previously where fuel is seeping out the front of the carb or now the only issue is that it will bog when giving it throttle?
Didn’t notice any fuel seeping.......so far. Just bogs when giving it throttle. Won’t even rev up enough to move it but it Idles beautifully. Put the choke on half way and I can drive around.
Last edited:
If it runs with the choke engaged, would that mean there's a possible air leak? Considering you have remove and replaced the carb rack multiple times and the symptom remains, I doubt the issue is related to not properly seating the mouth of the carbs into the intake rubber flanges but you might want to inspect them just to ensure there are no cracks. I do feel your pain as I was in the same boat where I could not get my carbs to sync and ran rough even at idle. Although each year I would disassemble the carbs, clean and soak jets, and reassemble, I couldn't figure out what I was doing wrong this time around. I wish I could tell you what component or a combination of components were the culprit after rebuilding my carbs, fuel pumps and replacing the filters but unfortunately, I just performed all of the work at once rather than replace individually to see what difference it made. I do know that none of my jets were plugged or gummed up but ended up replacing anyway. I know you replaced the needle valve assy which I did as well but I also replaced all four pilot screws. I was just going to order the replacement o-ring but the kit that included the pilot jet, spring, washer, and o-ring wasn't much more so opted for that instead. Hate to steer you down the path of replacing parts when they might not need it but am just relaying what I did to get mine running again.
Thank you for the follow through on your progress. I'm about to revive a 04 that has not been rode for 12 years. IKR! life throws ya curves. But it was drained of fuel and run dry before being covered and might have had 2000 miles on the clock. I'm expecting to need to pull the rack but fingers crossed.
RobX-1, might you have the part number/source for the fuel pump rebuild kits? A great source for actual Mikuni genuine parts?
Rexnak, I got the fuel pump rebuild kit from this source:

The kit will come with extra gaskets due to the fuel pump being used in other applications where only the difference was the inlet configuration so don't be alarmed like I was when trying to figure out what you missed when re-assembling. To be honest, unless you are certain you have a fuel pump issue, you may not need to rebuild. I thought I did and when I disassembled, I fudged up one of the paper gaskets so had to rebuild due to the leak I caused. Since I was only concerned with the gasket portion of this kit, I did not replace the two circular diaphragms and their two rubber grommets.

With that said and knowing the RX-1 you'll be working on had been sitting for 12 years, you may indeed need to rebuild due to gaskets dry-rotting. Best advice I can give when rebuilding fuel pumps is 1.) pay attention and document the order of gaskets [i.e. how they are layered] and 2.) do one at a time so as to be able to have one as a reference if needed on how its assembled.
Thanks RobX-1, For the link, Winderosa might have thrown me off. Are they not Mikuni pumps?
And, thanks for the legit advise.
For sure I will wait to order or rebuild till i get her started and see how well she wakes up.
Thank you for the follow through on your progress. I'm about to revive a 04 that has not been rode for 12 years. IKR! life throws ya curves. But it was drained of fuel and run dry before being covered and might have had 2000 miles on the clock. I'm expecting to need to pull the rack but fingers crossed.
RobX-1, might you have the part number/source for the fuel pump rebuild kits? A great source for actual Mikuni genuine parts?
The fuel pumps are mikuni brand,the part # for mikuni kit is#mk-df525-31 this only does 1 pump so you would need 2,these pumps are supposedly not rebuildable&no service parts are available from yamaha but,there are several places on line that carry the mikuni brand kit,You could order the kits to have on hand but those pumps are super tough,if it was me I would clean the carbs,prime the pumps &spray fuel in carbs&try starting,even though they sat a long time the system was drained&they may be ok.you will know right away if they leak or won't pump fuel then you could overhaul.
Thank You Brotherdan.
No problem,also if it was me&since the fuel system was drained I would not take the rack of carbs off the sled,just unhook the airbox,carb boots etc&flip over&remove bowls ( one at a time)usually pilot jets get plugged..I just dont think they will be bad enough to warrant removal from machine&a fair amount more work with coolant lines,throttle cable etc.If they are really bad after 1 bowl is removed you could pull the rack otherwise clean 1& reassemble &move to the next
Bypassed it and still the same.
Question about tors?been rereading all your old posts,when you bypassed the tors you connected them together on the harness side correct? They act super funky when tors is enabled&still sounds like it’s that just looking to confirm